Home
Tuesday, April 25, 2017
12:54:18 PM
Users online: 0   You are here >> Home > Networking

Forums | Networking Forums search
Forum FAQ
   
  1  
ftp server connection problems
illdrift 
25/8/08 7:29:02 PM
Overlord

I'm trying to set up an ftp server on my computer. It works fine within the network, but my mate can't access it through the internet. If we both run hamachi and ftp with the hamachi ip it works fine, but using the internet ip to connect comes up with "425 Can't open data connection.".

I'm guessing the router is the problem, it's a dynalink rta1025w. I've tried forwarding ports 20,21 and 990 to my ip address, it doesn't seemed to have helped. I can't see any other settings for packet filtering in the router. I'm using filezilla to host the ftp server.

Any ideas?

Edit: Windows firewall also disabled


Edited by illdrift: 25/8/2008 07:37:16 PM

-----
Desktop|xfx 790i|q6600@450x8(h2o)|2x2GB@1600-777|3xVX2640W|8800gt(h2o)| 2x8600gt(passive)|LG GGC-H20L|CoolMax 480w(passive)|

Nas|iCute Super18|msi 680i|e4300|2x640gb Rd1|HighPoint 2320|5x1tb Rd5|TX750W|

Master_Scythe 
25/8/08 7:41:42 PM
Titan

OK steps to set up FTP (i hope you mean sFTP)

1. Install the client (i use freeSSHd, has an sftp option)

2. turn off all firewalls.

3. forward ports from your router, to your local IP.

4. connect (winscp works well)

If step 3 is a problem, find the setting in your router for 'DMZ'
On home routers, all this does is open all ports to your PC, as its meant ot be used on a diferent PC to your main network.

But its a nice stopgap solution for a short period of time. Just try not to leave it like that. or if you do, install a software firewall at least.

I just use PortableHamachi (called Buri if you wanna DL it) and windows file shares for all my needs.

-----
4200+X2 939, ASUS A8N-SLI-D, Ati HD3850, 1gb,1tb total HDD, 109 DVD, LG DVD-rom.
Quote by Girvo
I've got a wicked tiny one that is ridiculously sensitive.



garlic 
25/8/08 9:13:01 PM
Overlord

the problem with FTP and firewalls is that the data channel is random in active mode (by the sounds of things, what you are running), and selected on the client. I suggest you run your client in "passive" mode and give that a crack. I think the ftp command is just "passive"

Also make sure ports 20 + 21 are forwarded on your router.

hope this helps

-----

illdrift 
26/8/08 1:16:14 PM
Overlord

Thanks guys.

DMZ allowed it to work (disabled now), as did setting the server to passive mode and specifying the ports to use, and then forwarding those ports on the router.

-----
Desktop|xfx 790i|q6600@450x8(h2o)|2x2GB@1600-777|3xVX2640W|8800gt(h2o)| 2x8600gt(passive)|LG GGC-H20L|CoolMax 480w(passive)|

Nas|iCute Super18|msi 680i|e4300|2x640gb Rd1|HighPoint 2320|5x1tb Rd5|TX750W|

  1  
Forums | Networking